Modified Mastering Maintenance

Maintenance

Modified Mastering Maintenance

Status: Closed
Start:
End:
Duration: 8 hours
Affected Components:
Higher Education Courseware Mastering
Update

During this time, access to Modified Mastering courseware will be unavailable. All other Mastering courseware will be available throughout the duration of the maintenace.

Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.