StatCrunch access issue

Incident

StatCrunch access issue

Status: Closed
Start:
End:
Duration: 53 minutes
Affected Components:
Higher Education Courseware StatCrunch
Update

We are investigating an issue with StatCrunch, as a result, customers may see an error message when attempting to log in or access the content. We will update you in the next 60 minutes with more information.

Update

We have remediated the issue and are currently monitoring the environment. We apologize for the inconvenience caused. 

Resolved

We appreciate your patience while we addressed this issue. This incident is now resolved.