Degraded Account Registration Performance
Incident
2025-08-25T17:21:00.0000000Z
Degraded Account Registration Performance
Status: Closed
Start:
2025-08-25T16:49:00.0000000Z
End:
2025-08-25T17:21:00.0000000Z
Duration: 32 minutes
Affected Components:
Higher Education Courseware
English Language Learning
English Benchmark Young Learners (EBYL)
MyEnglishLab (MEL)
Mastering
Pearson English Connect (PEC)
Pearson English Portal (PEP)
MyLab
Pearson English Portal App
Pearson Practice English (PPE) App
Pearson +
Pearson Test of English (PTE)
Revel
Test Hub
Reader+ / eBook / eText
Third-Party Learning Management Systems
Benchmark Test
MyLab & Mastering - Third-Party
International Certificate (PTE General)
Level Test
Readiness Test
Update
2025-08-25T16:49:00.0000000Z
2025-08-25T16:49:00.0000000Z
We're getting customer reports that they are experiencing slowness when creating accounts. We are working to restore services and will update you in 60 minutes.
Resolved
2025-08-25T17:21:00.0000000Z
2025-08-25T17:21:00.0000000Z
We appreciate your patience while we addressed this issue. This incident is now resolved.