Q-Global Maintenance

Maintenance

Q-Global Maintenance

Status: Closed
Start:
End:
Duration: 2 hours 12 minutes
Affected Components:
Clinical Assessments Q-Global
Update

Q-Global is under maintenance. During this time, access will be unavailable due to system maintenance. 

Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.