Degraded Performance

Incident

Degraded Performance

Status: Closed
Start:
End:
Duration: 1 hour 28 minutes
Affected Components:
Higher Education Courseware Mastering MyLab Pearson + Revel
Update

We're getting customer reports that they cannot create or launch courses. We are working to restore services and will update you in 60 minutes.

Update

We have confirmed a technical issue that may impact your Pearson+, Revel and MyLabs and Mastering services. Some customers may be unable to launch, create or copy courses. Teams are working on resolving this issue; we apologize for any inconvenience. 

Resolved

Systems are fully operational, and we have resolved this incident. We appreciate your patience as we worked to address the issue