Scheduled Maintenance: Revel

Maintenance

Scheduled Maintenance: Revel

Status: Closed
Start:
End:
Duration: 1 day 11 hours 50 minutes
Affected Components:
Higher Education Courseware Revel
Update

Revel will be undergoing maintenance on March 14th from 12:30AM until 9AM EST. During this time, assignment launch and assignment submission may be degraded or temporarily unavailable. Thank you for your patience.

Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.