Upcoming Maintenance: Mastering, MathXL, StatCrunch, and MyLab
Maintenance
2026-05-16T05:00:00.0000000Z
Upcoming Maintenance: Mastering, MathXL, StatCrunch, and MyLab
Status: Closed
Start:
2026-05-13T13:00:00.0000000Z
End:
2026-05-16T05:00:00.0000000Z
Duration: 2 days 16 hours
Affected Components:
Higher Education Courseware
Mastering
MathXL For School
MyLab
StatCrunch
Third-Party Learning Management Systems
MyLab & Mastering - Third-Party
Update
2026-05-13T13:00:00.0000000Z
2026-05-13T13:00:00.0000000Z
We will be performing system maintenance on Saturday, May 16th from 1am ET to 9am ET. During this time, access to course content will be either degraded or unavailable.
Resolved
2026-05-16T05:00:00.0000000Z
2026-05-16T05:00:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.