Scheduled Maintenance: My English Lab
Maintenance
2026-08-22T08:00:00.0000000Z
Scheduled Maintenance: My English Lab
Status: Closed
Start:
2026-08-22T07:00:00.0000000Z
End:
2026-08-22T08:00:00.0000000Z
Duration: 1 hour
Affected Components:
English Language Learning
MyEnglishLab (MEL)
Update
2026-08-22T07:00:00.0000000Z
2026-08-22T07:00:00.0000000Z
We are performing system maintenance on Saturday, August 22nd from 3am ET to 4am ET. During this time, My English Lab content will be either degraded or unavailable.
Resolved
2026-08-22T08:00:00.0000000Z
2026-08-22T08:00:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.