Scheduled Maintenance: Pearson Online Classroom
Maintenance
2026-08-15T00:20:00.0000000Z
Scheduled Maintenance: Pearson Online Classroom
Status: Closed
Start:
2026-08-15T00:00:00.0000000Z
End:
2026-08-15T00:20:00.0000000Z
Duration: 20 minutes
Affected Components:
Pearson Virtual Schools
Pearson Online Classroom
Update
2026-08-15T00:00:00.0000000Z
2026-08-15T00:00:00.0000000Z
Pearson Online Classroom will be undergoing scheduled maintenance beginning at approximately 8:00 p.m. ET on Friday, August 14, 2026.
We expect service to be restored within 20 minutes. At the start of the maintenance window, users will be logged out. While maintenance is ongoing, pages will be slow to load.
Resolved
2026-08-15T00:20:00.0000000Z
2026-08-15T00:20:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.